Relative cell reference nedir?

0
8

Bu makale, Relative cell reference’nin ne olduğunu ve Relative cell reference’nin nasıl kullanılacağını ayrıntılı olarak açıklayacaktır.

göreli hücre başvurusu

Göreli hücre referansı, bir hücrenin veya hücre grubunun aynı elektronik tablodaki başka bir hücreden ne kadar uzakta olduğunu tanımlar. Bir elektronik tablo formülüyle uğraşırken, göreli hücre başvurusu, bir formülün varsayılan davranışıdır. Örneğin, A2 ve B2 hücrelerini birlikte eklemek için C2 hücresinde “=TOPLA(A2+B2)” formülünü kullanabilirsiniz. Bu formülü C3 hücresine kopyalarsanız, C3’e göreli olur ve “=TOPLA(A3+B3)” olur.

Göreli hücre başvurusu örneği

=A2

Yukarıdaki formül, elektronik tablo programına ilk sütun (A) ve ikinci satırdaki (2) hücreyi kaplayan değeri göstermesini söylüyor. Excel elektronik tablosu örnek resmini kullanarak, bu formül B8 hücresine yerleştirilseydi, bu değer A2 hücresinde olduğu için “100” gösterecekti.

Daha önce belirtildiği gibi, göreli hücre başvuruları, Excel’e eklenen herhangi bir formülün varsayılan davranışıdır. Hücre, satır veya sütun formülü başvurularının değişmesini önlemek için, dolar işaretiyle ($) başlayan herhangi bir sütun veya satır olan mutlak hücre başvurusunu kullanarak kopyalayın.

Göreli sütun ve mutlak satır başvurusu

=A$2

Yukarıdaki formül, mutlak satır referansına sahip göreli bir sütun kullanır. Hücre formülü kopyalanmış olsaydı, satır her zaman aynı kalırdı (2). Ancak, sütun kopyalandığı yere göre olacaktır.

Göreli satır referanslı mutlak sütun

=$A2

Yukarıdaki formül, göreli satır başvurusuyla birlikte mutlak bir sütun başvurusu kullanır. Hücre formülü kopyalanmış olsaydı, sütun her zaman aynı kalırdı (A). Ancak satır, kopyalandığı yere göre olacaktır.

Göreceli hücre referansı ile mutlak hücre referansı

=SUM($A$2+B2)

Son olarak, yukarıdaki formül her zaman A2’deki değeri kullanır, ancak bu değeri bir sonraki göreli hücreye ekler. Hücre formülü C2’den C3’e kopyalanmışsa, “=SUM($A$2+B3)” olur.

Kısacası, göreli hücre referansını mutlak hücre referansından farklı kılan şey, formülü farklı hücrelere kopyalamanın veya taşımanın onların değişmesine neden olmasıdır. Mutlak hücreler, formülün veya başvurunun nerede göründüğünden bağımsız olarak her zaman tam olarak açıklanan satırı veya sütunu gösterir.

LEAVE A REPLY

Please enter your comment!
Please enter your name here