Absolute cell reference nedir?

0
6

Bu makale, Absolute cell reference’nin ne olduğunu ve Absolute cell reference’nin nasıl kullanılacağını ayrıntılı olarak açıklayacaktır.

Mutlak hücre referansı

Microsoft Excel ve diğer elektronik tablo programlarında, bir mutlak hücre başvurusu veya ACR, kopyalansa veya taşınsa bile aynı kalan bir elektronik tablo hücresidir.

Mutlak hücre referansına genel bakış

Hücrenin formülüne bakarak mutlak bir hücre referansı belirlenebilir. Formül bir veya daha fazla dolar işareti ($) içeriyorsa, bu bir mutlak hücre başvurusu veya kısmi bir mutlak hücre başvurusudur. Aşağıdaki örnekte, formül çubuğu, mutlak hücre başvurusu değil, göreli hücre başvurusu olan “=TOPLA(D2:D5)” ifadesini gösterir.

Mutlak hücre başvurusu örnekleri

Mutlak sütun ve mutlak satır referansı

=$A$2

Yukarıdaki formül, elektronik tablo programına, geçerli hücredeki A1 hücresinin değerini göstermesini söylüyor. Örneğin, yukarıdaki Excel elektronik tablosuyla, bu formülü B8 hücresine girersek, A2 hücresindeki değer bu olduğundan her zaman “100” olur.

Mutlak hücre referansını göreli bir hücre referansından (örneğin, =A2) farklı kılan şey, hücre formülünü B8’e kopyalayıp B9’a yerleştirdiğimizde “100” kalmasıdır. Göreceli bir hücre başvurusu, değeri için sonraki göreli hücreyi kullanır; bu hücrede A3 olur ve hücrede “101” değerine sahip olur.

  • Excel elektronik tablosunda metin ve formüller nasıl kopyalanır ve yapıştırılır.

Göreli sütun ve mutlak satır başvurusu

=A$2

Yukarıdaki formül, mutlak satır referansına sahip göreli bir sütun kullanır. Hücre formülü kopyalandıysa, satır aynı kalır (2), ancak sütun kopyalandığı yere göredir.

Göreli satır referanslı mutlak sütun

=$A2

Yukarıdaki formül, göreli satır referansına sahip mutlak bir sütun referansıdır. Hücre formülü kopyalandıysa, sütun aynı kalır (A), ancak satır kopyalandığı yere göredir.

Göreceli hücre referansı ile mutlak hücre referansı

=SUM($A$2+B2)

Son olarak, yukarıdaki formül her zaman A2’deki değeri kullanır, ancak bu değeri bir sonraki göreli hücreye ekleyin. Hücre formülü C2’den C3’e kopyalanmışsa, “=SUM($A$2+B3)” olur.

Kısacası, göreli hücre referansını mutlak hücre referansından farklı kılan şey, formülü farklı hücrelere kopyalamanın veya taşımanın onların değişmesine neden olmasıdır. Mutlak hücreler, başvurunun nerede göründüğünden bağımsız olarak her zaman tam olarak açıklanan satırı veya sütunu gösterir.

Neden birinin mutlak bir hücre referansı kullanması gerekiyor?

Mutlak hücre referansı, göreli hücre referansı kadar kullanılmaz. Ancak, bir formülü birden çok hücreye kopyalamanız gerektiğinde mutlak hücre başvurusu kullanmak yardımcı olabilir. Örneğin, birden çok hücrede her zaman aynı hücre değerini kullanan bir formüle ihtiyacınız varsa, göreli bir hücre başvurusu kullanıyorsa, kopyalandığında değerleri değiştirir. Bununla birlikte, formül mutlak bir hücre başvurusu içeriyorsa, herhangi bir yere kopyalanabilir ve her zaman aynı hücre değerini koruyabilir.

LEAVE A REPLY

Please enter your comment!
Please enter your name here